<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424,115551496","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":0,"applicationTime":503,"agent":""}</script>
<script>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</script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='guce.rivals.com' name='oath:guce:consent-host'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  var googleAnalyticsId = "UA-81742375-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansFonts-7bf9e355b46ff060654c148212a35d40cb49b73381f27a9833dcc432fff1c97a.css' rel='stylesheet'>
<title>ASUDevils  -  Bell ready for the challenge at starting center</title>
<meta content='ASUDevils  -  Bell ready for the challenge at starting center' property='og:title'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-28f7e9f8b5e36d846a0976742fba6bb1a7dd9adc2006371d3f80e9792d3b44c3.css" />


<script src="https://cdn.rivals.com/production/assets/lib-12381f29bb2a6e1cd6ab2484aa7e729e8f72a6f1457e3a239ac156581f11a919.js"></script>
<script src="https://cdn.rivals.com/production/assets/application-ae47702e860d0208681b49a40d344e1f884d9a27b8119a9a66ea1c0cc6579d18.js"></script>

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="1nHHiaQi51AoBloe+J6l87WW7NfQds58BrE79a3Bvn1Cd8B/p7Xo9JZ5lA42VTPTYeG6+MM9bBBoR3YeqR0ypA==" />
<script>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</script>
</script>

<script>
  (function () {
    'use strict';
    angular.module('rivals').factory('baseAppSettings', function () {
  
      var getPremiumIcon = function() {
        return "";
      };
  
      var singleSiteApp = function() {
        return "false";
      };
  
      return {
        getPremiumIcon: getPremiumIcon,
        singleSiteApp: singleSiteApp
      };
    });
  }).call(this);
</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://arizonastate.rivals.com/news/bell-ready-for-the-challenge-at-starting-center' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_headline_primary/iceo5gk3felmkb3p4vau' property='og:image'>
<meta content='Redshirt freshman not daunted by the unexpected starting position this year' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2019-08-02 12:52:02 -0500' property='article:published_time'>
<meta content='2019-08-02 12:52:05 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='apple-touch-icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "arizonastate.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='arizonastate contents-show' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  /*doc
     ---
     title: Yahoo Heading & Body
     category: typography
     ---
   ```haml_example
  .font-yahoo-h2 Font Yahoo H2
  .font-yahoo-h3 Font Yahoo H3
  .font-yahoo-h4 Font Yahoo H4
  
  .font-yahoo-b4 Font Yahoo B4
  .font-yahoo-b5 Font Yahoo B5
   ```
  */
  @media screen and (max-width: 1023px) {
    .arizonastate #programming > h1 {
      background-color: #82022c !important; } }
  .arizonastate .wrapper-container .team-colors-line {
    background-color: #ecbd00; }
  .arizonastate img.custom-premium-icon, .arizonastate .custom-premium-icon, .arizonastate img.custom-premium-white-icon, .arizonastate .custom-premium-white-icon,
  .arizonastate img.custom-premium-gallery-icon, .arizonastate .custom-premium-gallery-icon, .arizonastate .premium-icon-container {
    display: none; }
  .arizonastate .team-colors-line {
    width: 100%;
    height: 8px;
    display: flex;
    background-color: #82022c; }
    .arizonastate .team-colors-line .color {
      width: 33.33%; }
    .arizonastate .team-colors-line .first-opacity {
      background-color: white;
      opacity: 0.2; }
    .arizonastate .team-colors-line .second-opacity {
      background-color: white;
      opacity: 0.4; }
    .arizonastate .team-colors-line.vertical {
      flex-direction: column;
      height: auto;
      width: 8px; }
      .arizonastate .team-colors-line.vertical .color {
        width: 100%;
        height: 33.33%; }
    .arizonastate .team-colors-line.header {
      height: 6px; }
  .arizonastate > header .notification-link .count-container {
    background-color: #82022c !important; }
  .arizonastate > header .wrapper-container {
    background-color: #82022c !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .arizonastate > header .wrapper-container {
        border-bottom: 6px solid #ecbd00 !important; } }
  .arizonastate > header .invalid-email-banner {
    background-color: #82022c;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .arizonastate > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .arizonastate > header .invalid-email-banner a:hover {
      color: #ecbd00; }
  @media screen and (max-width: 767px) {
    .arizonastate > header .mobile-header {
      background-color: #ecbd00 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .arizonastate > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .arizonastate > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .arizonastate > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .arizonastate > header .nav-row > ul,
    .arizonastate > header .third-nav {
      background-color: white !important; }
    .arizonastate > header .dropdown-toggle > i.fa {
      color: #82022c !important; } }
  .arizonastate > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #82022c; }
  
  .site-primary-font-color {
    color: #82022c; }
  
  .site-primary-background-color {
    background-color: #82022c; }
  
  .site-secondary-font-color {
    color: #ecbd00; }
  
  .site-secondary-background-color {
    background-color: #ecbd00; }
  
  .team-background-image {
    background-image: linear-gradient(rgba(130, 2, 44, 0.4), rgba(130, 2, 44, 0.4)), url();
    background-repeat: no-repeat;
    background-position: center; }
  
  :root {
    --primary-color: #82022c;
    --secondary-color: #ecbd00;
    --accent-color: #82022c;
    --button-color: #82022c;
    --subscription-button-color: #0A4EA3; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-cloak ng-controller='NavController as ctrl' ng-init='ctrl.init(false,"arizonastate")' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Arizona State" class="site-header" ng-class="ctrl.teamSite ? &quot;team&quot; : &quot;no-team&quot;" href="https://arizonastate.rivals.com/"><img src="https://res-4.cloudinary.com/rivals/image/upload/azx6xuevw5znty4ibegy" alt="Azx6xuevw5znty4ibegy" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span class='upsell-text'>
            Join the team!
          </span>
          <a ng-href='{{ ctrl.subscribePath + ctrl.utmParams }}'>
            Subscribe
          </a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && !ctrl.isMobile'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://arizonastate.rivals.com/">Home</a></li>
        <rv-forum-navigation site-identifier="&#39;arizonastate&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://arizonastate.rivals.com/">Home</a></li>
        <rv-forum-navigation site-identifier="&#39;arizonastate&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert class='alert-nav'></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733072,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Bell ready for the challenge at starting center"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='DevilsDigest' name='twitter:site'>
<meta content='Bell ready for the challenge at starting center' name='twitter:title'>
<meta content='Redshirt freshman not daunted by the unexpected starting position this year' name='twitter:description'>
<meta content='https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/iceo5gk3felmkb3p4vau' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {"id":7,"legacy_id":1056,"name":"ASUDevils","friendly_name":"Arizona State","annual_discount":null,"subdomain":"arizonastate","primary_color":"82022c","secondary_color":"ecbd00","font_color":"ffffff","short_name":"arizonastate","maple_ncaaf_team_id":58,"maple_ncaaf_endpoint":"ncaaf/teams/aam","maple_ncaab_team_id":18,"maple_ncaab_endpoint":"ncaab/teams/aar","maple_college_id":58,"google_analytics_id":"UA-81742375-1"}, true, 188, nil, {"id":122,"primary_color":"82022c","secondary_color":"ecbd00","font_color":"ffffff","commitment_module_football":true,"rivals_module_football":true,"header_name":"","header_logo_cloudinary":"azx6xuevw5znty4ibegy","mobile_header_logo_cloudinary":null,"google_analytics_id":"UA-81742375-1","logo_background_shading":"white","football_content":true,"basketball_content":true,"baseball_content":true,"other_content":true,"site_id":7,"created_at":"2016-11-23T13:38:44.116-06:00","updated_at":"2019-01-14T19:00:07.392-06:00","max_trending_articles":6,"enrichments":[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":2},{"active":false,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":null},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":3},{"active":false,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardPhotos","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"FanFuturecastLeaderboard","football":null,"list_id":null,"list_title":null,"position":null}],"footer_text":null,"sections":[],"supplied_domain":null,"forums_link_url":"https://arizonastate.forums.rivals.com","scoreboard_scores_id":null,"scoreboard_photos_id":null,"aol_player_id":"5964f567c214e305c80c59d6","aol_company_id":"595e9e782a30cb7ee3e53959","ad_frequency":5,"display_twitter_follow":true,"display_fb_follow":true,"follow_twitter_handle":"DevilsDigest","follow_fb_handle":"DevilsDigest","forum_id":null,"premium_forum_id":null,"facebook_page_id":null,"max_ticker_articles":7,"schedule_header_on":true,"promo_popup_on":false,"facebook_developer_id":null,"customized_tos":[],"show_survey_popup":false,"survey_popup_link":null,"header_bottom_border_style":"solid","premium_icon_url":null,"customized_upsell_banner_text":null,"custom_premium_icon_enabled":null,"email_logo_cloudinary":null},&#x000A;"5964f567c214e305c80c59d6", "595e9e782a30cb7ee3e53959", "rivals", 15000, false, {"id":141,"user_id":8492,"site_id":7,"updated_at":"2017-08-01T18:24:35.770-05:00","publisher_name":"Hod Rabino","first_name":"Hod","last_name":"Rabino","site_title":"Publisher","bio":"Longest tenured beat writer for Arizona State football and basketball, and a Website Publisher since 2001.","twitter_handle":"DevilsDigest","image_url":"https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_author_bio/emkua9fk2mp6ml2de2su","publisher_name_and_title":"Hod Rabino, Publisher","site_name":"ASUDevils","site_short_name":"arizonastate","has_edited_profile":true})'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>

<div class='article-container' ng-class='{"no-ad-padding": "#{@display_ldrb_top}"}'>
<div class='upsell-forecast-banner' ng-cloak='true'>
<rv-user-forecast-banner class='forecast-banner' upsell='true'></rv-user-forecast-banner>
</div>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header'>
News
<a href="/more_news#other-news"><span class='more-news-link'>
More News
</span>
</a></div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' premium_icon='null' profile_page='false' referral_code='referralCode' team='false'></rv-news-ticker>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":34,"image_id":31451,"url":"\u003ca href=\"http://www.cactussports.com/\" target=\"_blank\"\u003e\u003cimg border=\"1\u0026quot;\" src=\"https://ct.yimg.com/mr/uploads/1056/1664818.jpg\"\u003e\u003c/a\u003e","position":1,"site_id":7,"created_at":"2016-01-12T15:56:47.542-06:00","updated_at":"2016-01-17T23:08:54.265-06:00","image_url":"https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/qaj8njvl3xhcv6p0tmos"}' class='ad-one'></rv-custom-ad>

<rv-forums ad-referer='https://arizonastate.rivals.com/news/bell-ready-for-the-challenge-at-starting-center' base-api-url='https://arizonastate.forums.rivals.com/' forums-url='https://arizonastate.forums.rivals.com' homepage='false' pub-ad='null' size='size' space-id='2022733072' subscribed-user='subscribedUser'></rv-forums>

<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://arizonastate.rivals.com/news/bell-ready-for-the-challenge-at-starting-center/printable' site-name='ASUDevils'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2019-08-02 12:52:02 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(publishedSite)}}//publishing/contents/2065019/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Bell ready for the challenge at starting center</h2>
<div class='header-image'><figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/iceo5gk3felmkb3p4vau','https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto/iceo5gk3felmkb3p4vau')">
<div class='image-container'>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" src="https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/iceo5gk3felmkb3p4vau" alt="Iceo5gk3felmkb3p4vau" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Jarrett Bell: &quot;I’m not the guy yet...I just got to work hard every single day and make sure that I can keep this position now.”</figcaption>
</div>
</figure>
</div>
<div class='author-byline'>
<div class='title-sm' id='onetime-author'>Chris Gleason</div>
<div class='type-sm'>Staff Writer</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p><br></p><p>Jarrett Bell didn’t even play on the offensive side of the ball until his senior season of high school. Now, two years later, the redshirt freshman has been thrust into the role of ASU’s starting center, flanked by four seniors on the offensive line.</p><p>The result of senior tackle Zach Robertson’s sudden and seemingly indefinite absence from the team, due to personal matters, projects Bell to be a regular starter a year earlier than expected. </p><p>But if you thought the Norco, California native would be caught off-guard by being thrown in with the starters, you’d be mistaken.</p><p>“I’m definitely excited to take on this role,” Bell said. “In practice, I’ve been working for the last eight months at center, so I’ve picked it up very well. I feel more comfortable actually at center than I do at guard or tackle.”</p><p>“It didn’t spook him,” head coach Herm Edwards said. “He’s in a good spot right now, mentally.”</p><p>Although Bell has yet to see game action as a center, in either high school or college, he’s been working closely with senior Cohl Cabral.</p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ia33jpm3pulmrxmg35ry','https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto/ia33jpm3pulmrxmg35ry')">
<div class='image-container'>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" src="https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ia33jpm3pulmrxmg35ry" alt="Ia33jpm3pulmrxmg35ry" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Jarrett Bell: “Throughout the year and in games, I was on the sidelines...picking up stuff what the center’s doing.&quot;</figcaption>
</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p><br></p><p>Prior to being shuffled to left tackle out of necessity, Cabral was named to the Rimington Trophy watch list just two weeks ago, an honor that goes to the nation’s top center.</p><p>In fact, Bell mentioned Cabral in his first sentence of being interviewed after Thursday’s practice- completely unprovoked- simply asked how prepared he felt to take on this challenge.</p><p>“I’ve been working behind Cohl Cabral for the last year and I’ve been picking up everything he’s been doing,” Bell said. “Right now, I’m just working on playing that to the game this whole Fall camp, trying to pick up the speed and the tempo of the first team. If I keep doing the stuff I’m supposed to do every day, work my technique, I’ll be good.”</p><p>Talking to Bell, it’s evident how key Cabral has been to his development since setting foot in Tempe, and also how much respect he has for the senior’s skills.</p><p>“Cohl’s helped me tremendously throughout the season, just showing me how to attack this defense, mostly of ours,” Bell said. “He’s taught me a lot; how to be patient, my hands, my footwork, so he’s definitely a guy that’s helped me throughout this process.”</p><p>Another thing that helped him was redshirting the 2018 season, which allowed him to see the game a whole new way from what he’s used to.</p><p>“Throughout the year and in games, I was on the sidelines with coach (Kevin) Mawae watching the game and picking up stuff what the center’s doing,” Bell said, “picking up what the guards are doing, seeing how defenses move, seeing it from a different perspective than actually being on the field.</p><p>“(Mawae) can’t coach us, but just to have him around and just have his presence is amazing, but we’ve got (offensive line) coach (Dave) Christensen, who’s an amazing coach, he’s been helping me along this process along with Cohl Cabral.”</p><p>Even though Bell appears fully ready to embrace his newfound role as the starting center, he understands how much more goes into the position than any of the others on the offensive line.</p><p>He may have become more comfortable playing center over the past year than guard or tackle- his positions during his senior season in high school- but he’s well versed on the responsibilities that will come with it. </p><p>“At center you’re king of the offense,” Bell said. “You make all the calls, you control the snap count, you control the blocking scheme, so you got to make sure you know your offense, and make sure you know the defense as well.”</p><p>There are no secrets on what he has to improve on either, and especially on what it will take to mesh with a group of all seniors as a redshirt freshman.</p><p>“I still have a few things I got to work on, the protections and my pass blocking when I’m one-on-one versus an odd front,” Bell said.</p><p>“I just got to be able to put my head in the film room and be physical at practice, stick to my technique and do what the coaches say, and then if I play well, it will be embedded very well in the offense.” </p><p>Granted, Bell has certainly worked with a lot of offensive line gurus to help him even be in a position to become a starter under these urgent circumstances. </p><p>Yet, arguably just as significant as the knowledge and skills he’s absorbed to date is the respect he’s earning from his head coach throughout this whole process.</p><p>Edwards, like any shrewd football mind, knows the value of experience when it comes to playing on the offensive line. Nonetheless, it would seem hard-pressed to find another inexperienced lineman on the Sun Devils who Edwards respects more than Bell.</p><p>“Experience,” Edwards said of the biggest thing that will help Bell learn the position, “offensive line especially, because that’s why it takes these guys so long to kind of grow.”</p><p>“But look, (Bell) worked his tail off last year…that’s what this thing’s about, it’s about developing young guys, and when opportunity knocks you got to go, and right now he’s doing a pretty good job.”</p><p>While expressing his excitement for the opportunity in front of him, the redshirt freshman has maintained a proper perspective on where he stands as a starter.</p><p>“I’m not the guy yet,” Bell admitted. “They gave me the position because someone’s out, I got to earn the position and let the coaches know I can play it, so at the moment, I just got to work hard every single day and make sure that I can keep this position now.”</p><p>If anyone has set a benchmark for him on what it will take to be successful long-term at playing center, it would have to be none other than Cabral. </p><p>In working so closely with him for such a long period of time (at least by a college standard), Bell has come to appreciate the nuances of being a consistently strong center.</p><p>“When he was at center, he can get down, he can pick up a whole defense exactly where they’re going, their coverages, Bell described, “where their d-line’s going, and put our blocking scheme perfectly to match that so we can pick up the pressures, or any corner cats, or safety dropping, and that’s the biggest thing I’m trying to pick up from him right now. </p><p>“If I can be able to dissect a whole defense like that, we’ll be good.”</p><p>Bell still has nearly four weeks to get up to speed with the starters before opening night, and if he can progress how he hopes to, no one will even notice who the freshman is amongst the seniors.</p><p>“I’ve got a whole line of seniors and I’ve got to make sure I compete up to their level because they’ve been here playing with each other for the last five years,” Bell said. “I got to make sure that I can’t let them down this year because this is a huge year for our team.”</p><p><i>Join us on our premium message board, the </i><a href="https://arizonastate.forums.rivals.com/forums/devils-huddle.22/"><b><i>Devils’ Huddle</i></b></a><i>, to discuss this article and other ASU football and recruiting topics. Not a member yet?</i><a href="https://arizonastate.rivals.com/news/fall-camp-subscription-promotion-25-off-75-ecard-to-the-adidas-store"><b> Sign up today here </b></a><i>and</i></p><p>receive 25% off + $75 eCard to the Adidas store!</p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/bxjsp3otoxsqzy9gmcdx','https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto/bxjsp3otoxsqzy9gmcdx')">
<div class='image-container'>
<a href='http://www.cactussports.com/' target='_blank'>
<img class="" src="https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/bxjsp3otoxsqzy9gmcdx" alt="Bxjsp3otoxsqzy9gmcdx" />
</a>
</div>
</figure>
</div>
<div class='text-center'>
<rv-share-links print-url='https://arizonastate.rivals.com/news/bell-ready-for-the-challenge-at-starting-center/printable' site-name='ASUDevils'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>
</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2018' ncaaf-schedule-year='2019' site='{"id":7,"legacy_id":1056,"name":"ASUDevils","friendly_name":"Arizona State","annual_discount":null,"subdomain":"arizonastate","primary_color":"82022c","secondary_color":"ecbd00","font_color":"ffffff","short_name":"arizonastate","maple_ncaaf_team_id":58,"maple_ncaaf_endpoint":"ncaaf/teams/aam","maple_ncaab_team_id":18,"maple_ncaab_endpoint":"ncaab/teams/aar","maple_college_id":58,"google_analytics_id":"UA-81742375-1"}' twitter-feed='{"id":7,"site_id":7,"handle":"DevilsDigest","list_name":"Devils-Digest","created_at":"2016-02-01T12:24:40.327-06:00","updated_at":"2016-02-01T16:55:06.268-06:00","hashtags":[],"usernames":[],"max_number":null}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://arizonastate.rivals.com/news/bell-ready-for-the-challenge-at-starting-center/printable' site-name='ASUDevils'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733072', 'https://arizonastate.rivals.com/news/bell-ready-for-the-challenge-at-starting-center');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Bell ready for the challenge at starting center";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div ng-controller='googleTagManagerController as ctrl' ng-init='ctrl.init("arizonastate", 2065019, null)'>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
<noscript>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
</noscript>
</div>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":34,"image_id":31451,"url":"\u003ca href=\"http://www.cactussports.com/\" target=\"_blank\"\u003e\u003cimg border=\"1\u0026quot;\" src=\"https://ct.yimg.com/mr/uploads/1056/1664818.jpg\"\u003e\u003c/a\u003e","position":1,"site_id":7,"created_at":"2016-01-12T15:56:47.542-06:00","updated_at":"2016-01-17T23:08:54.265-06:00","image_url":"https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/qaj8njvl3xhcv6p0tmos"}' class='ad-one'></rv-custom-ad>
</div>
</div>

</div>
</main>
<footer>
<!-- t('footer.about_link', primary_host: primary_host) -->
<ul class='footer-links list-inline'>
<li>
<a href='/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='/news/member-services'>Help</a>
</li>
</ul>
<div class='logo-container'>
<div class='footer-logo'></div>
</div>
<div class='copyright-notice'>Certain data provided by STATS, LLC<br/>© 2019 Verizon Media. All rights reserved.</div>
</footer>

</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733072",
    c7: "https://arizonastate.rivals.com/news/bell-ready-for-the-challenge-at-starting-center"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Farizonastate.rivals.com%2Fnews%2Fbell-ready-for-the-challenge-at-starting-center&c5=2022733072&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
